0

Using monero-gui-v0.13.0.3 on Ubuntu 18.04 LTS (all up to date), starting this way: ./start-gui.sh, and with the Nano Ledger S (up to date: Firmware version 1.4.2), all is well (I allow the viewing of the keys from the Ledger when prompted, and I can see my wallet balance number on the gui) until the daemon starts.

The terminal shows:

2018-10-27 17:42:35,350 INFO [default] Page size: 4096 2018-10-27 17:42:36.354 7f98cc6b3780 INFO global src/daemon/main.cpp:287 Monero 'Beryllium Bullet' (v0.13.0.2-release) Forking to background...

And it just hangs from there. The gui is frozen.

(Earlier, I had to do sudo apt-get install libhidapi-libusb0, as noted elsewhere, to even get the gui to start).

Additionally, when I try to clean up the monerod processes with ./monerod exit, that hangs as well.

How can I run the new gui on Ubuntu 18.04 LTS?

1

When a process hangs, you can use gdb to work out where it is hanging:

  gdb /path/to/binary PID  

Replace /path/to/binary with the filename (and path if needed) of the binary you're running, and PID with the PID of the running process (you can get it via ps).

Then, when in gdb:

  thread apply all bt  

This will print a list of all the threads and what they are doing. If any of those threads are stuck somewhere, this should expose it.

0

Answering my own question: Indeed, everything eventually worked; I rebooted and started the gui, not touching any controls on it for a few hours. After that stretch of time, the wallet was fully synchronized and the wallet worked normally. The odd thing about this was that my machine is Intel i7 QuadCore, so it was very odd to see the gui locked up for some unknown number of minutes/an hour+. Thanks to the posters below who suggested that the blockchain conversion to the new format was the trigger.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.