1

When I try to send a transaction from the 0.13.0.3 GUI, I keep getting stuck with an error:

Can't create transaction: internal error: Daemon response did not include the requested real output

I tried to close the wallet and open it back, but nothing changes.

I also tried from the 0.13.0.3 CLI, unfortunately the problem is the same.

I tried on multiple different computers (with same keys), but the issue is still the same.

Now I can see that the unlocked balance has this status (waiting for blocks):

enter image description here

The problem happened after I tried to send moneros from the Monero wallet GUI v0.11.1.0 (please check this post: How to unlock a PENDING order in Monero Wallet GUI?). The order was stucked with PENDING status during hours, so I updated to Wallet v0.13.0.3 and was finally able to cancel the order. Then I tried again to send money to the same address, but it didn't work and I am still stucked since.

EDIT

The weirdest point is that I can't no more access my key with the wallet v0.11.1.0, I have an error "Couldn't open wallet: invalid password". Still working with v0.13.0.3

EDIT

Here are some of the last daemon logs:

You are now synchronized with the network. You may now start monero-wallet-cli.
2018-10-23 10:43:48.270 [P2P2]  INFO    global  src/blockchain_db/lmdb/db_lmdb.cpp:600  [batch] DB resize needed
2018-10-23 12:06:53.123 [P2P0]  WARN    global  src/p2p/net_node.inl:1338       [1;31mNo incoming connections - check firewalls/routers allow port 18080[0m
2018-10-23 12:35:11.569 [P2P5]  ERROR   blockchain      src/cryptonote_core/blockchain.cpp:2380 Borromean range proofs are not allowed after v8
2018-10-23 14:22:20.833 [P2P8]  WARN    net.dns src/common/dns_utils.cpp:519    WARNING: no two valid MoneroPulse DNS checkpoint records were received

Is there something wrong there?

2

You can open a 0.11 wallet with 0.13, but not the other way around. The format was updated, and encryption was strenghtened. Once you've updated, you can't go back.

Are you using the same daemon version as wallet version ? If not, that's probably the problem.

In particular, a 0.11 daemon will not be able to sync current blocks, so will not know about any newer output of yours.

For the record, for a testnet wallet (which is not your case here, but putting it here in case people find this), then the problem may also be that you had outputs on the old testnet chain, as it was reorganized after a small consensus change in bulletproof format.

  • Thank for the explanation why I can't open the key anymore. Yes I am using the same daemon version as wallet. – 118218 Oct 23 '18 at 15:12
  • I can confirm I was able to sync all blocks, so I am probably using the good wallet – 118218 Oct 23 '18 at 15:13
  • Do you have an idea what I can do to withdraw my coins? I want to send them to an exchange to sell them.. – 118218 Oct 23 '18 at 15:14
  • 1
    Best bet is probably to rescan your wallet from seed, but since there is an apparent bug in either the wallet or daemon, it's not clear this will fix it. Or run "rescan_bc" in monero-wallet-cli, which is a last chance fix command, and will lose some info (tx secret keys, history which cannot be recovered from the blockchain). You can keep a backup of your current wallet cache though. – user36303 Oct 23 '18 at 20:39
  • I already tried the command "rescan_bc" and also to rescan the wallet from seed, but unfortunately nothing seems to work. – 118218 Oct 24 '18 at 4:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.