1

I've run into a really frustrating issue with my Ledger Nano S and the Monero wallet, and can't seem to get it to work again. The wallet was working previously and now no longer detects my Ledger anymore. I have already run through all the incredibly tedious steps of creating the wallet:

  • Booting into recovery mode
  • Disabling SIP
  • Rebooting
  • Adding the necessary smart card ID keys to the Info.plist file
  • Booting into recovery mode
  • Renabling SIP
  • Restart

This allowed me to create the wallet using the GUI and I synced it and sent funds to my wallet and I could see them in the wallet and the wallet was working well.

About a week later I tried to access the wallet again and I am now getting the same error I was getting before I installed the wallet:

Couldn't open wallet: Fail SCard API : (-2146435069) Invalid handle. Device=0, hCard=0, hContext=1

I've done the following to try rectify this but to no avail:

  • Checked the USB cable and verified it's working and is the same one I used when creating the wallet and received the funds.
  • I've opened the Info.plist file and verified that those keys still exist and are the same as when the wallet was working
  • Restarted numerous times
  • Booted into recovery mode and disabled SIP again
  • Tried all USB ports on my MAC
  • Gone through pretty much every Ledger / Monero related issue on this forum

But still I haven't been able to get it working again. I was using a USB hub when I first installed it and I'm wondering if that was maybe the problem? Surely if it detects the device on one USB port then any port should work thereafter? At this stage I'm really grasping at straws as I have no idea how to get it working again and no longer have access to my funds - very frustrating.

I know a new version of the GUI is coming out mid-way through October to solve all these issues with Macs but would like to access my funds before then if possible!

Any help would be great (ಥ﹏ಥ)

Thanks in advance

  • 1
    Have you tried using a different USB cable (even though you verified that the current one should be working properly)? – dEBRUYNE Sep 23 '18 at 13:26
  • Out of frustration I went and bought a new cable. lo and behold.. it worked! thanks man appreciate it! If you add this as the answer I'll mark it as solved (☞゚∀゚)☞ – Nick Kirsten Sep 24 '18 at 9:01
  • You're welcome and I'll add an answer later today. – dEBRUYNE Sep 24 '18 at 10:23
  • Don't forget to add that answer sir so I can mark it off. otherwise I'll add the answer just in case anyone else runs into the same frustrating issue – Nick Kirsten Sep 26 '18 at 15:14
  • Ah, kind of forgot. I'll add one know. – dEBRUYNE Sep 26 '18 at 15:53
1

The predominant reason for a properly working Ledger & Monero setup to stop working is that the USB cable is either broken or slightly damaged (and therefore unable to function properly). Fortunately, this particular issue is easily resolved by buying a new USB cable. Alternatively, it could be that the USB port is not functioning properly anymore. You can easily check whether this is the culprit of your issue by using a different USB port.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.