0

I'm a beginner to Monero. I managed to create a ledger wallet using the monero GUI and fully sync the daemon. I also succeeded in funding my wallet.

When i later wanted to try the CLI version, i used the --data-dir command to point to the same location on my D: drive, to avoid having to wait for the syncing process.

This fails however, every time the daemon is started it terminates before starting sync.

This is the log output:

\monerod.exe --limit-rate 128 --data-dir "D:\Full node\Monero\Blockchain"

2018-08-21 19:40:33.209 4788 INFO logging contrib/epee/src/mlog.cpp:186 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO

2018-08-21 19:40:33.210 4788 INFO global src/daemon/main.cpp:282 Monero 'Lithium Luna' (v0.12.3.0-release)

2018-08-21 19:40:33.210 4788 INFO global src/daemon/protocol.h:53 Initializing cryptonote protocol...

2018-08-21 19:40:33.210 4788 INFO global src/daemon/protocol.h:58 Cryptonote protocol initialized OK

2018-08-21 19:40:33.211 4788 INFO global src/daemon/p2p.h:63 Initializing p2p server...

2018-08-21 19:40:37.305 4788 INFO global src/daemon/p2p.h:68 p2p server initialized OK

2018-08-21 19:40:37.616 4788 INFO global src/daemon/rpc.h:63 Initializing core RPC server...

2018-08-21 19:40:37.617 4788 INFO global contrib/epee/include/net/http_server_impl_base.h:76 Binding on 127.0.0.1:18081

2018-08-21 19:40:37.617 4788 INFO global src/daemon/rpc.h:69 core RPC server initialized OK on port: 18081

2018-08-21 19:40:37.618 4788 INFO global src/daemon/core.h:86 Initializing core...

2018-08-21 19:40:37.619 4788 INFO global src/cryptonote_core/cryptonote_core.cpp:427 Loading blockchain from folder D:\Full node\Monero\Blockchain\lmdb ...

Later. I tried to remove the spaces in the path, making it: "d:/FullNode/Monero/Blockchain. It didnt help.

Finally, when trying to go back to using the GUI, i get the same problem. The daemon starts and terminates after the same line, making me unable to access my funds.

Has my blockchain data become corrupted somehow? I tried removing the lock files but that didnt help either.

I hope anyone has some good ideas. I will try to resync into a new directory, but that might take a few days..

Thank you.

  • Do you get an error message in a message dialog or the like ? Nothing in this log seems untowards. You can also run with "--log-level 1" to see if anything more comes up in the log. – user36303 Aug 22 '18 at 18:02
  • I tried running with --log-level 1 but i still dont see any concrete error messages. The last lines are : >>>>>>>>>>>>>>> 2018-08-22 18:23:28.957 12876 INFO blockchain.db.lmdb src/blockchain_db/lmdb/db_lmdb.cpp:530 Space remaining: 14353309696 2018-08-22 18:23:28.957 12876 INFO blockchain.db.lmdb src/blockchain_db/lmdb/db_lmdb.cpp:531 Size threshold: 0 2018-08-22 18:23:28.957 12876 INFO blockchain.db.lmdb src/blockchain_db/lmdb/db_lmdb.cpp:533 Percent used: 0.8128 Percent threshold: 0.8000 – Monstolord Aug 22 '18 at 18:26
  • So you're saying monerod just exits, no error message at all ? – user36303 Aug 22 '18 at 19:09
  • Yeah, seems like it. The cmd window just closes itself before starting synchronization. The only idea i have left is that somehow the data got corrupted. When running monerod targeting an empty folder it started syncing without any problems. Just a pity if i have to wait several days to get back into my wallet. – Monstolord Aug 22 '18 at 20:12
1

I deleted the data and did a full resync. It took a few days but everything is working fine now. I must have corrupted it somehow, possibly by terminating the daeamon or GUI in the wrong way.

So if anyone has the same problem (monerod.exe terminating on startup), probably the best solution is to resync.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.